sdut java实验7.1

2024-05-01 16:20
文章标签 java 实验 7.1 sdut

本文主要是介绍sdut java实验7.1,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

7-1 sdut-JAVA-Pig Latin

分数 12

全屏浏览

切换布局

作者 马新娟

单位 山东理工大学

Write a program that requests a word as input, translates the word into Pig Latin and outputs the word input and its equivalent in Pig Latin. The rules for translating a word are as follows:

Rule 1: If a word begins with a consonant, move the first letter to the end of the word and add ay to the end of the word. For example, Chip becomes hipCay.

Rule 2: If the word begins with a vowel, add way to the end of the word. For example, else becomes elseway.

Input Specification:

Request a word as input.

Output Specification:

Outputs the word input and its equivalent in Pig Latin.

Sample Input1:

 

Sample Output1:

No input provided to convert to Pig Latin.

Sample Input2:

123anksO

Sample Output2:

Input should comprise of alphabetic characters only.

Sample Output3:

123anksO

Sample Output3:

Input should comprise of alphabetic characters only.

Sample Output4:

day

Sample Output4:

Word Input: day
Pig Latin: ayday

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

栈限制

8192 KB

import java.util.Scanner;public class Main {public static void main(String[] args) {Scanner sc = new Scanner(System.in);String arr = sc.nextLine();if(arr.isBlank()){System.out.println("No input provided to convert to Pig Latin.");System.exit(0);}for(int i = 0;i<arr.length();i++){if(Character.isDigit(arr.charAt(i))){System.out.println("Input should comprise of alphabetic characters only.");System.exit(0);}}if(arr.charAt(0) == 'a'||arr.charAt(0) == 'e'||arr.charAt(0) == 'i'||arr.charAt(0) == 'o'||arr.charAt(0) == 'u'||arr.charAt(0) == 'A'||arr.charAt(0) == 'E'||arr.charAt(0) == 'I'||arr.charAt(0) == 'O'||arr.charAt(0) == 'U'){System.out.println("Word Input: "+arr);System.out.println("Pig Latin: "+arr+"way");System.exit(0);}else {System.out.println("Word Input: "+arr);System.out.print("Pig Latin: ");for(int i = 1;i<arr.length();i++){System.out.print(arr.charAt(i));}System.out.print(arr.charAt(0)+"ay");}}
}
 

import java.util.Scanner;

导入Java的Scanner类,用于读取用户的输入。

 

public class Main {

定义了一个名为Main的公共类。

 

public static void main(String[] args) {

定义了程序的入口点main方法。

 

Scanner sc = new Scanner(System.in);

创建了Scanner类的一个实例sc,用于从标准输入读取数据。

 

String arr = sc.nextLine();

读取用户输入的一整行文本,并将其存储在字符串变量arr中。

 

if(arr.isBlank()){

检查用户输入的字符串是否是空白的(只包含空格或没有字符)。

 

System.out.println("No input provided to convert to Pig Latin.");

如果输入是空白的,打印一条消息并退出程序。

 

System.exit(0); }

使用System.exit(0)来正常退出程序。

 

for(int i = 0; i < arr.length(); i++){

遍历字符串arr中的每个字符。

 

if(Character.isDigit(arr.charAt(i))){

检查当前字符是否是数字。

 

System.out.println("Input should comprise of alphabetic characters only.");

如果输入包含数字,打印一条消息并退出程序。

 

System.exit(0); } }

结束for循环和if语句。

 

if(arr.charAt(0) == 'a' || arr.charAt(0) == 'e' || arr.charAt(0) == 'i' || arr.charAt(0) == 'o' || arr.charAt(0) == 'u' || arr.charAt(0) == 'A' || arr.charAt(0) == 'E' || arr.charAt(0) == 'I' || arr.charAt(0) == 'O' || arr.charAt(0) == 'U'){

检查字符串arr的第一个字符是否是元音字母。

 

System.out.println("Word Input: "+arr);

打印原始输入的单词。

 

System.out.println("Pig Latin: "+arr+"way");

对于以元音开头的单词,将"way"添加到单词的末尾,并打印结果。

 

System.exit(0); }

结束if语句,并退出程序。

 

else {

如果第一个字符不是元音字母,执行else代码块。

 

System.out.println("Word Input: "+arr);

打印原始输入的单词。

 

System.out.print("Pig Latin: ");

打印"Pig Latin: "作为输出的开始。

 

for(int i = 1; i < arr.length(); i++){

从字符串arr的第二个字符开始遍历,直到最后一个字符。

 

System.out.print(arr.charAt(i));

在for循环中,打印当前索引处的字符。

 

}

结束for循环。

 

System.out.print(arr.charAt(0)+"ay");

将原始单词的第一个字符和"ay"拼接,并打印出来,形成猪拉丁表达。

 

}

结束else代码块。

 

}

结束main方法。

 

}

结束Main类。

这个程序首先检查输入是否有效,然后根据猪拉丁的规则将输入的单词转换为猪拉丁形式。对于以元音开头的单词,它简单地在单词后面加上"way"。对于以辅音开头的单词,它将第一个辅音移动到单词的末尾,并加上"ay"。

这篇关于sdut java实验7.1的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/952121

相关文章

Java 实用工具类Spring 的 AnnotationUtils详解

《Java实用工具类Spring的AnnotationUtils详解》Spring框架提供了一个强大的注解工具类org.springframework.core.annotation.Annot... 目录前言一、AnnotationUtils 的常用方法二、常见应用场景三、与 JDK 原生注解 API 的

Java controller接口出入参时间序列化转换操作方法(两种)

《Javacontroller接口出入参时间序列化转换操作方法(两种)》:本文主要介绍Javacontroller接口出入参时间序列化转换操作方法,本文给大家列举两种简单方法,感兴趣的朋友一起看... 目录方式一、使用注解方式二、统一配置场景:在controller编写的接口,在前后端交互过程中一般都会涉及

Java中的StringBuilder之如何高效构建字符串

《Java中的StringBuilder之如何高效构建字符串》本文将深入浅出地介绍StringBuilder的使用方法、性能优势以及相关字符串处理技术,结合代码示例帮助读者更好地理解和应用,希望对大家... 目录关键点什么是 StringBuilder?为什么需要 StringBuilder?如何使用 St

使用Java将各种数据写入Excel表格的操作示例

《使用Java将各种数据写入Excel表格的操作示例》在数据处理与管理领域,Excel凭借其强大的功能和广泛的应用,成为了数据存储与展示的重要工具,在Java开发过程中,常常需要将不同类型的数据,本文... 目录前言安装免费Java库1. 写入文本、或数值到 Excel单元格2. 写入数组到 Excel表格

Java并发编程之如何优雅关闭钩子Shutdown Hook

《Java并发编程之如何优雅关闭钩子ShutdownHook》这篇文章主要为大家详细介绍了Java如何实现优雅关闭钩子ShutdownHook,文中的示例代码讲解详细,感兴趣的小伙伴可以跟随小编一起... 目录关闭钩子简介关闭钩子应用场景数据库连接实战演示使用关闭钩子的注意事项开源框架中的关闭钩子机制1.

Maven中引入 springboot 相关依赖的方式(最新推荐)

《Maven中引入springboot相关依赖的方式(最新推荐)》:本文主要介绍Maven中引入springboot相关依赖的方式(最新推荐),本文给大家介绍的非常详细,对大家的学习或工作具有... 目录Maven中引入 springboot 相关依赖的方式1. 不使用版本管理(不推荐)2、使用版本管理(推

Java 中的 @SneakyThrows 注解使用方法(简化异常处理的利与弊)

《Java中的@SneakyThrows注解使用方法(简化异常处理的利与弊)》为了简化异常处理,Lombok提供了一个强大的注解@SneakyThrows,本文将详细介绍@SneakyThro... 目录1. @SneakyThrows 简介 1.1 什么是 Lombok?2. @SneakyThrows

在 Spring Boot 中实现异常处理最佳实践

《在SpringBoot中实现异常处理最佳实践》本文介绍如何在SpringBoot中实现异常处理,涵盖核心概念、实现方法、与先前查询的集成、性能分析、常见问题和最佳实践,感兴趣的朋友一起看看吧... 目录一、Spring Boot 异常处理的背景与核心概念1.1 为什么需要异常处理?1.2 Spring B

如何在 Spring Boot 中实现 FreeMarker 模板

《如何在SpringBoot中实现FreeMarker模板》FreeMarker是一种功能强大、轻量级的模板引擎,用于在Java应用中生成动态文本输出(如HTML、XML、邮件内容等),本文... 目录什么是 FreeMarker 模板?在 Spring Boot 中实现 FreeMarker 模板1. 环

SpringMVC 通过ajax 前后端数据交互的实现方法

《SpringMVC通过ajax前后端数据交互的实现方法》:本文主要介绍SpringMVC通过ajax前后端数据交互的实现方法,本文给大家介绍的非常详细,对大家的学习或工作具有一定的参考借鉴价... 在前端的开发过程中,经常在html页面通过AJAX进行前后端数据的交互,SpringMVC的controll