【PAT】1075. PAT Judge (25)【结构体的使用】

2024-04-12 06:18
文章标签 使用 25 结构 pat 1075 judge

本文主要是介绍【PAT】1075. PAT Judge (25)【结构体的使用】,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

题目描述

The ranklist of PAT is generated from the status list, which shows the scores of the submittions. This time you are supposed to generate the ranklist for PAT.

翻译:PAT的排名是根据显示提交的得分情况的状态表进行排名的,这一次你需要得出PAT的排名表。

INPUT FORMAT

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (<=104), the total number of users, K (<=5), the total number of problems, and M (<=105), the total number of submittions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submittion in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either -1 if the submittion cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括3个正整数N(<=10^4),用户总数,K(<=5),题目总数,和M(<=10^5),提交总数。假设用户id是一个从00001到N的5位数字,问题的编号为从1到K。第二行包括K个正整数p[i] (i=1,…k),p[i]代表第i题的满分分数。接着M行,每行按照以下格式给出一个提交记录:
user_id problem_id partial_score_obtained
如果提交不能通过编译器,则 得分为-1,否则为一个[0,p[problem_id]]的整数。一行内所有数字之间用空格隔开。

OUTPUT FORMAT

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] … s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

翻译:对于每组测试数据,你需要按照以下格式输出:
rank user_id total_score s[1] … s[K]
rank根据总分排名,所有拥有相同分数的用户获得同样的排名;s[i]代表第i题的部分得分。如果用户有一题没有提交过结果,则需要在对应位置输出“-”。如果一个用户一道题提交了多次,则输出最高的分数。
排名表必须按照排名升序输出。对于那些排名相同的人,用户必须按照完美解决题目的个数进行降序排序。如果仍然相同,则他们必须根据他们的id号进行升序输出。对于那些提交过题目未通过编译或从未提交过题目的人,他们将不会在排名中显示。数据保证至少有一个用户可以被展示在排名表上。


Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -


解题思路

模拟题目要求即可,只要有一道题得分>=0,就参与排名。根据总分->满分题目个数->ID号大小的方式排序。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<vector>
#include<algorithm>
#define INF 99999999
using namespace std;
int N,K,M; 
int score[10];
struct Stu{int id,sum,sco[10],flag;Stu(){sum=0;for(int i=0;i<10;i++)sco[i]=-2;flag=0;}int getSum(){for(int i=1;i<=K;i++){if(sco[i]>0)sum+=sco[i];if(sco[i]>=0&&!flag)flag++;if(sco[i]==score[i])flag++;}return flag;}bool operator<(const Stu &a)const{return sum==a.sum?(flag==a.flag?id<a.id:flag>a.flag):sum>a.sum;}
};
Stu stu[10010];
vector<Stu> ans;
int main(){scanf("%d%d%d",&N,&K,&M);for(int i=1;i<=K;i++)scanf("%d",&score[i]);int Tid,Tnum,Tscore; for(int i=0;i<M;i++){scanf("%d%d%d",&Tid,&Tnum,&Tscore);stu[Tid].id=Tid;stu[Tid].sco[Tnum]=max(stu[Tid].sco[Tnum],Tscore);}for(int i=1;i<=N;i++){if(stu[i].getSum())ans.push_back(stu[i]);}sort(ans.begin(),ans.end());int Grade=0,Score=-1;for(int i=0;i<ans.size();i++){if(ans[i].sum!=Score)Grade=i+1,Score=ans[i].sum;printf("%d %05d %d",Grade,ans[i].id,ans[i].sum);for(int j=1;j<=K;j++){if(ans[i].sco[j]>0)printf(" %d",ans[i].sco[j]);else if(ans[i].sco[j]>=-1)printf(" 0",ans[i].sco[j]);else printf(" -");}printf("\n");}return 0;
}

这篇关于【PAT】1075. PAT Judge (25)【结构体的使用】的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/896333

相关文章

使用animation.css库快速实现CSS3旋转动画效果

《使用animation.css库快速实现CSS3旋转动画效果》随着Web技术的不断发展,动画效果已经成为了网页设计中不可或缺的一部分,本文将深入探讨animation.css的工作原理,如何使用以及... 目录1. css3动画技术简介2. animation.css库介绍2.1 animation.cs

使用雪花算法产生id导致前端精度缺失问题解决方案

《使用雪花算法产生id导致前端精度缺失问题解决方案》雪花算法由Twitter提出,设计目的是生成唯一的、递增的ID,下面:本文主要介绍使用雪花算法产生id导致前端精度缺失问题的解决方案,文中通过代... 目录一、问题根源二、解决方案1. 全局配置Jackson序列化规则2. 实体类必须使用Long封装类3.

Python文件操作与IO流的使用方式

《Python文件操作与IO流的使用方式》:本文主要介绍Python文件操作与IO流的使用方式,具有很好的参考价值,希望对大家有所帮助,如有错误或未考虑完全的地方,望不吝赐教... 目录一、python文件操作基础1. 打开文件2. 关闭文件二、文件读写操作1.www.chinasem.cn 读取文件2. 写

PyQt6中QMainWindow组件的使用详解

《PyQt6中QMainWindow组件的使用详解》QMainWindow是PyQt6中用于构建桌面应用程序的基础组件,本文主要介绍了PyQt6中QMainWindow组件的使用,具有一定的参考价值,... 目录1. QMainWindow 组php件概述2. 使用 QMainWindow3. QMainW

使用Python自动化生成PPT并结合LLM生成内容的代码解析

《使用Python自动化生成PPT并结合LLM生成内容的代码解析》PowerPoint是常用的文档工具,但手动设计和排版耗时耗力,本文将展示如何通过Python自动化提取PPT样式并生成新PPT,同时... 目录核心代码解析1. 提取 PPT 样式到 jsON关键步骤:代码片段:2. 应用 JSON 样式到

java变量内存中存储的使用方式

《java变量内存中存储的使用方式》:本文主要介绍java变量内存中存储的使用方式,具有很好的参考价值,希望对大家有所帮助,如有错误或未考虑完全的地方,望不吝赐教... 目录1、介绍2、变量的定义3、 变量的类型4、 变量的作用域5、 内存中的存储方式总结1、介绍在 Java 中,变量是用于存储程序中数据

关于Mybatis和JDBC的使用及区别

《关于Mybatis和JDBC的使用及区别》:本文主要介绍关于Mybatis和JDBC的使用及区别,具有很好的参考价值,希望对大家有所帮助,如有错误或未考虑完全的地方,望不吝赐教... 目录1、JDBC1.1、流程1.2、优缺点2、MyBATis2.1、执行流程2.2、使用2.3、实现方式1、XML配置文件

macOS Sequoia 15.5 发布: 改进邮件和屏幕使用时间功能

《macOSSequoia15.5发布:改进邮件和屏幕使用时间功能》经过常规Beta测试后,新的macOSSequoia15.5现已公开发布,但重要的新功能将被保留到WWDC和... MACOS Sequoia 15.5 正式发布!本次更新为 Mac 用户带来了一系列功能强化、错误修复和安全性提升,进一步增

Java资源管理和引用体系的使用详解

《Java资源管理和引用体系的使用详解》:本文主要介绍Java资源管理和引用体系的使用,具有很好的参考价值,希望对大家有所帮助,如有错误或未考虑完全的地方,望不吝赐教... 目录1、Java的引用体系1、强引用 (Strong Reference)2、软引用 (Soft Reference)3、弱引用 (W

ubuntu系统使用官方操作命令升级Dify指南

《ubuntu系统使用官方操作命令升级Dify指南》Dify支持自动化执行、日志记录和结果管理,适用于数据处理、模型训练和部署等场景,今天我们就来看看ubuntu系统中使用官方操作命令升级Dify的方... Dify 是一个基于 docker 的工作流管理工具,旨在简化机器学习和数据科学领域的多步骤工作流。