poj 2251Dungeon Master(BFS, DFS亦可)

2024-03-15 10:48

本文主要是介绍poj 2251Dungeon Master(BFS, DFS亦可),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

               今天,一看题,我就想到用BFS,毕竟BFS是具有贪心性质的,可以用来求最小短的……给我的感觉就是简单,但是很烦,因为它是三维的,和poj3728 catch that cow差不多,需要一个数组来存储到达那一点的最小的时间;需要注意的是,输出‘.’;

Dungeon Master
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9761 Accepted: 3777

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.######
#####
##.##
##...#####
#####
#.###
####E1 3 3
S##
#E#
###0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!


#include<stdio.h>
#include<string.h>
struct Node
{int x;int y;int z;
}node[170000];
int l, r, c;char map[31][31][31];
int visited[31][31][31];
int step[31][31][31];int x1, y1, z1;
int x2, y2, z2;
int a[6][3]={{-1,0,0},{1,0,0},{0,-1,0},{0,1,0},{0,0,-1},{0,0,1}};int BFS(int x, int y, int z)
{int i;int X, Y, Z;int front=0, rear=1;node[front].x=x;node[front].y=y;node[front].z=z;visited[z][y][x]=1;while(front != rear){for(i=0; i<6; i++){X=node[front].x+a[i][0];Y=node[front].y+a[i][1];Z=node[front].z+a[i][2];if(X>=0&&X<c && Y>=0&&Y<r && Z>=0&&Z<l && !visited[Z][Y][X] && map[Z][Y][X]!='#'){step[Z][Y][X]=step[node[front].z][node[front].y][node[front].x]+1;if( X==x2 && Y==y2 && Z==z2){return 1;}node[rear].x=X;node[rear].y=Y;node[rear].z=Z;visited[Z][Y][X]=1;rear++;}}front++;	}return 0;	
}
int main()
{int i, j, k;while(scanf("%d %d %d", &l, &r, &c) && l){memset(visited, 0, sizeof(visited) );memset(step, 0, sizeof(step) );for(i=0; i<l; i++){for(j=0; j<r; j++){getchar();for(k=0; k<c; k++){scanf("%c", &map[i][j][k]);if(map[i][j][k]=='S'){z1=i;y1=j;x1=k;}else if(map[i][j][k]=='E'){z2=i;y2=j;x2=k;}else if(map[i][j][k]=='#')visited[i][j][k]=1;}}getchar();}if( BFS(x1, y1, z1) )printf("Escaped in %d minute(s).\n", step[z2][y2][x2]);elseprintf("Trapped!\n");}	
}

这篇关于poj 2251Dungeon Master(BFS, DFS亦可)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/811708

相关文章

windos server2022里的DFS配置的实现

《windosserver2022里的DFS配置的实现》DFS是WindowsServer操作系统提供的一种功能,用于在多台服务器上集中管理共享文件夹和文件的分布式存储解决方案,本文就来介绍一下wi... 目录什么是DFS?优势:应用场景:DFS配置步骤什么是DFS?DFS指的是分布式文件系统(Distr

hdu1254(嵌套bfs,两次bfs)

/*第一次做这种题感觉很有压力,思路还是有点混乱,总是wa,改了好多次才ac的思路:把箱子的移动当做第一层bfs,队列节点要用到当前箱子坐标(x,y),走的次数step,当前人的weizhi(man_x,man_y),要判断人能否将箱子推到某点时要嵌套第二层bfs(人的移动);代码如下:

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

poj 1511 Invitation Cards(spfa最短路)

题意是给你点与点之间的距离,求来回到点1的最短路中的边权和。 因为边很大,不能用原来的dijkstra什么的,所以用spfa来做。并且注意要用long long int 来存储。 稍微改了一下学长的模板。 stack stl 实现代码: #include<stdio.h>#include<stack>using namespace std;const int M

poj 3259 uva 558 Wormholes(bellman最短路负权回路判断)

poj 3259: 题意:John的农场里n块地,m条路连接两块地,w个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。 任务是求你会不会在从某块地出发后又回来,看到了离开之前的自己。 判断树中是否存在负权回路就ok了。 bellman代码: #include<stdio.h>const int MaxN = 501;//农场数const int

poj 1258 Agri-Net(最小生成树模板代码)

感觉用这题来当模板更适合。 题意就是给你邻接矩阵求最小生成树啦。~ prim代码:效率很高。172k...0ms。 #include<stdio.h>#include<algorithm>using namespace std;const int MaxN = 101;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int n

poj 1287 Networking(prim or kruscal最小生成树)

题意给你点与点间距离,求最小生成树。 注意点是,两点之间可能有不同的路,输入的时候选择最小的,和之前有道最短路WA的题目类似。 prim代码: #include<stdio.h>const int MaxN = 51;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int P;int prim(){bool vis[MaxN];

poj 2349 Arctic Network uva 10369(prim or kruscal最小生成树)

题目很麻烦,因为不熟悉最小生成树的算法调试了好久。 感觉网上的题目解释都没说得很清楚,不适合新手。自己写一个。 题意:给你点的坐标,然后两点间可以有两种方式来通信:第一种是卫星通信,第二种是无线电通信。 卫星通信:任何两个有卫星频道的点间都可以直接建立连接,与点间的距离无关; 无线电通信:两个点之间的距离不能超过D,无线电收发器的功率越大,D越大,越昂贵。 计算无线电收发器D

poj 1502 MPI Maelstrom(单源最短路dijkstra)

题目真是长得头疼,好多生词,给跪。 没啥好说的,英语大水逼。 借助字典尝试翻译了一下,水逼直译求不喷 Description: BIT他们的超级计算机最近交货了。(定语秀了一堆词汇那就省略吧再见) Valentine McKee的研究顾问Jack Swigert,要她来测试一下这个系统。 Valentine告诉Swigert:“因为阿波罗是一个分布式共享内存的机器,所以它的内存访问